Flashing an ISO image to an external drive like a USB stick or an SDCard is a common way to get up and running with a new system. The "classic" way of burning this to a CD-ROM is not really in use anymore. Still, many projects do provide images as ISO files.

This lists working approaches on MacOS to handle this task.

Overview of disks

A quick way to list the devices is to use diskutil:

$ diskutil list

It should show something like the following output:

/dev/disk3 (internal, physical):
  #:                       TYPE NAME                    SIZE       IDENTIFIER
  0:     FDisk_partition_scheme                        *8.0 GB     disk3
  1:                       0xEF                         36.7 MB    disk3s2

In my case this is a small SDCard which I entered.

Flashing the external drive

Flashing is best done using the command dd. I got good results with the following command line:

$ sudo dd bs=10m if=image.iso of=/dev/rdisk3

Note

Notice that I am using rdisk3 instead of disk3. This should increase the throughput a good chunk.

Monitoring status

dd has built-in status reporting on the command line, just send the signal INFO and it will print out the current status:

$ KILL -s INFO $PID_OF_dd

Comments

comments powered by Disqus